this is obsolete doc -- see http://doc.nethence.com/ instead

Solaris 11 post-installation 

 

Allow root login and put your SSH public keys in place, 

cd /etc/ssh/ 

cp sshd_config sshd_config.dist 

vi sshd_config 

PermitRootLogin yes 

svcadm restart sshd 

 

cd /etc/default/ 

cp login login.dist 

#CONSOLE=/dev/console 

 

rolemod -K type=normal root 

 

cd ~/ 

mkdir -p .ssh/ 

cd .ssh/ 

cat >> authorized_keys <<EOF 

KEYS HERE 

EOF 

 

You can now connect remotely. 

 

Make sure the system doesn't start gnome gdm at boot time, 

  svcadm disable application/graphical-login/gdm:default 

 

Allo admin user to switch to root, 

  usermod -R root adminuser 

 

Allow admin user to sudo, 

vi /etc/sudoers 

adminuser ALL=(ALL) ALL 

 

Fix the PATH setting and tweak the shell a little bit, 

vi .bash_profile 

source $HOME/.bashrc 

vi .bashrc 

typeset +x PS1="\u@\h:\w\\$ " 

export PATH=/bin:/usr/bin:/sbin:/usr/sbin:/usr/local/bin:/usr/local/sbin 

case "himBH" in *i*) 

alias ll='ls -alhF' 

alias rm='rm -i' 

alias cp='cp -i' 

alias mv='mv -i' 

;; 

esac 

source .bashrc 

 

Identify your network interface, 

svcs | grep network | grep physical 

dladm show-phys 

dladm show-link 

ipadm show-if 

 

Change the hostname and IP using this script (assuming an IP has previously been setup), 

#!/bin/bash 

newhost=HOSTNAME_HERE 

newip=IP_ADDRESS_HERE 

svccfg -s system/identity:node listprop config 

svccfg -s system/identity:node setprop config/nodename="$newhost" 

svccfg -s system/identity:node setprop config/loopback="$newhost" 

svccfg -s system/identity:node refresh 

svcadm restart system/identity:node 

svccfg -s system/identity:node listprop config 

hostname 

ipadm delete-addr net0/v4 

ipadm create-addr -T static -a $newip/24 net0/v4 

ipadm 

cat >> /etc/hosts <<EOF && echo /etc/hosts done 

$newip $newhost.example.com $newhost.example.local $newhost 

EOF 

 

Reduce the boot loader timeout from 30 to 3 seconds, 

bootadm list-menu 

bootadm set-menu timeout=3 

bootadm list-menu 

 

Install VMware Tools, 

VM > Guest > Install VMware Tools 

cp -R /cdrom/vmwaretools/ ~/ 

cd ~/vmwaretools/ 

tar xzf vmware-solaris-tools.tar.gz 

cd vmware-tools-distrib/ 

./vmware-install.pl 

check status and make sure it's enabled at startup, 

/etc/init.d/vmware-tools status 

find /etc/rc*.d/ | grep vmware 

Ref. https://docs.oracle.com/cd/E23824_01/html/821-1451/fahqr.html 

 

For ZFS see http://pbraun.nethence.com/unix/filesystems/zfs.html 

 

Refs. 

https://blogs.oracle.com/VDIpier/entry/solaris_11_changing_the_hostname 

https://docs.oracle.com/cd/E23824_01/html/821-1459/disksprep-3.html 

http://docs.oracle.com/cd/E19253-01/819-5461/6n7ht6r3m/index.html 

https://docs.oracle.com/cd/E23824_01/html/821-1448/gaynd.html 

https://docs.oracle.com/cd/E23824_01/html/821-1459/fscreate-6.html 

https://docs.oracle.com/cd/E23824_01/html/821-1459/disksprep-3.html 

http://solaris.kuehnke.de/archives/28-How-to-change-your-hostname-and-IP-Address-in-Solaris-11.html 

http://wiki.loopback.org/index.php/Change_IP_address_on_Solaris_11 

http://www.oracle.com/technetwork/articles/servers-storage-admin/s11-network-config-1632927.html 

http://thegeekdiary.com/how-to-configure-an-ip-address-in-solaris-11/ 

https://docs.oracle.com/cd/E23824_01/html/E24456/glhbr.html 

https://docs.oracle.com/cd/E23824_01/html/821-1458/gjwiq.html 

http://nutek.support/forum/viewtopic.php?t=451 

http://blog.allanglesit.com/2011/03/solaris-11-network-configuration-basics/