this is obsolete doc -- see http://doc.nethence.com/ instead

Configuring Oracle Solaris 10 

 

Installation 

During installation, provide the fully qualified domaine name e.g., 

solaris10.example.local

and choose Name Service, 

DNS

 

Post-installation 

Enter a decent shell, 

#ksh
#set -o emacs
bash

 

Disable the desktop user interface, 

/usr/dt/bin/dtconfig -d
/etc/init.d/dtlogin stop

Note. To enable it back, 

#/usr/dt/bin/dtconfig -e
#/etc/init.d/dtlogin stop

 

Fix the network configuration, 

cd /etc/
vi hosts
vi resolv.conf
cp nsswitch.conf nsswitch.conf.dist
vi nsswitch.conf (add 'dns' for the hosts and ipnodes entries)

 

Enable SSH (and eventually root login), 

#cd /etc/ssh/
#cp sshd_config sshd_config.dist
#vi sshd_config (permitrootlogin yes)
cd ~/
svcadm enable svc:/network/ssh:default
svcadm restart svc:/network/ssh:default

 

You should be able to connect to the host remotely. 

 

Eventually change the default shell to Bash, 

cd /etc/
vi passwd (root...:/usr/bin/bash)

 

Administrating the zones 

Verify that you are currently running a global zone (by default on Solaris 10 and over), 

zoneadm list -v

 

Create a (whole root -- no sparse) zone, 

ifconfig -a (check on which interface you may build an alias upon)
mkdir -p /data/zones/zone1/
cd /data/zones/zone1/
chmod 700 /data/zones/zone1/
zonecfg -z zone1

then, 

create
set zonepath=/data/zones/zone1
set autoboot=true
#add inherit-pkg-dir
#set dir=/opt/csw
#end
add net

set physical=xnf0 

set address=x.x.x.x 

set defrouter=x.x.x.x 

end
info
verify
commit
^D

note. Only share /opt/csw/ if it exists and if you've got software in it. 

check that the zone now exists and install the system binaries in it, 

zoneadm list -cv
zoneadm -z zone1 install

 

Start the newly created zone and see the interface alias it creates, 

zoneadm -z zone1 boot
ifconfig -a

enter its console, 

zlogin -C -e [ zone1

  (answer the questions to configure the pre-installed system) 

 

Refs. 

https://blogs.oracle.com/mandalika/entry/solaris_10_zone_creation_for 

http://hub.opensolaris.org/bin/view/Community+Group+zones/faq#HSection1:Basics 

http://solaris.reys.net/solaris-10-zones-part-one-a-working-example/