this is obsolete doc -- see http://doc.nethence.com/ instead
VSE Management software installation
HP SIM installation on HP/UX
You need to install this on a non VM host machine. Eventually a VM guest (which you will have to migrate manually if you need to shutdown its host.
Look for available bundles,
mkdir -p /cd1 /cd2
ioscan -fnC disk
mount /dev/dsk/c0t2d0 /cd1
mount /dev/dsk/c0t1d0 /cd2
swlist -s/cd1 | grep -i vse
swlist -s/cd2 | grep -i vse
Note. to provide the Virtual FileDVD from the VM host,
#hpvmmodify -P guest3 -a dvd:scsi::file:/data/vsoe_1.iso
#hpvmmodify -P guest3 -a dvd:scsi::file:/data/vsoe_2.iso
View what's already installed,
swlist -lbundle | grep -i vse
Note. after the installation you should get those,
T2786AC
VSEMgmt
VseAssist
Install some dependencies from DVD1,
swlist -lproduct -s/cd1 | grep -i joob
swinstall -s/cd1 -x autoreboot=true Joob
Note. check after reboot,
swlist -lproduct | grep -i joob
Mount the DVDs again,
mount /dev/dsk/c0t2d0 /cd1
mount /dev/dsk/c0t1d0 /cd2
Install VSE from DVD2,
swlist -s/cd2 | grep -i vse
swinstall -s/cd2 -x autoreboot=true VSEMgmt
Note. if anything fails, don't forget to clean up before you retry,
#swremove VSEMgmt
#swremove VseAssist
Note. otherwise add "-x reinstall=true" to swinstall commands
Note. check after reboot,
swlist -lbundle | grep -i vse
Note. to remove the Virtual FileDVD from the VM host,
#hpvmmodify -P guest3 -d dvd:scsi::file:/data/vsoe_1.iso
#hpvmmodify -P guest3 -d dvd:scsi::file:/data/vsoe_2.iso
You may use Oracle instead of PGSQL,
scp oracle@ORACLESERVER:/u01/product/11.1.0/ora1110/sqldeveloper/jdbc/lib/ojdbc14.jar /opt
ll /opt/*.jar
export PATH=$PATH:/opt/mx/bin
mxoracleconfig -h ORACLESERVER -n 1521 -d sim -u USERNAME -p PASSWORD -j /opt/ojdbc14.jar
note. the database needs to have the "AL32UTF8" character set
note. tablespace of 1GB and temporary tablespace of 100MB is fine. HP SIM and VSE installation takes around 100MB. The free space will be used for their application data.
note. the user USERNAME needs to have the "dba" role
note. if you need to start over, drop the user, recreate it and rerun mxoracleconfig with the '-f' option
Configure HP SIM,
export PATH=$PATH:/opt/mx/bin
mxinitconfig -l
mxinitconfig -a
note. if something goes wrong during the database configuration,
#cd /var/opt/mx/logs
#ls -ltr
note. you should get a "Completed all tasks successfully.", and tablespace used something about 50MB
note. I used to have the "hpsmdb failed to start" and "/sbin/init.d/hpsmdb[25]: 16637 Memory fault(coredump)" error, hence the Oracle choice
note. if you need to start over, remove the config (mxinitconfig -r) and proceed again
If you need the manuals,
MANPATH=`cat /etc/MANPATH`
export MANPATH
man mxinitconfig
VSE integration into HP SIM
Configure VSE Management software
export PATH=$PATH:/opt/vse/bin
vseinitconfig -a
note. you should get a "Completed all tasks successfully.", and tablespace now used something about 10MB more
note. if anything goes wrong,
#tail -100 /var/opt/vse/logs/vseinitconfig.log
Note this comment,
PLEASE NOTE: For assistance with licensing, refer to the VSE Management
Software Getting Started Guide or the vselicense man page...
==> VSE Management Software 90 day trial license applied for HP Integrity and
HP 9000 systems.
HP SIM configuration
Open those URLs,
https://HPSIMSERVER:280
https://HPSIMSERVER:50000
login to the latter with your system root password and proceed with the first time wizard (enable popups).
Proceed with the first time wizard (Options > First time wizard). You go through these steps,
Options > Managed environments
Options > Protocol Settings > Global Protocol Settings
Run a discovery,
Options > Discovery
System automatic discovery / Run now
HP SIM maintainance
Start the daemons (and go take a cup of coffee the time it starts...),
export PATH=$PATH:/opt/mx/bin
mxstart
#/sbin/init.d/hpsim start
note. Database needs to be started. Don't forger the listener if it's Oracle.
stop the daemons,
export PATH=$PATH:/opt/mx/bin
mxstop
#/sbin/init.d/hpsim stop