this is obsolete doc -- see http://doc.nethence.com/ instead
Configuring system's storage on HP/UX 11i (part 4)
Introduction
Note. The lvextend command is available on 11i v1 but not lvmerge.
Note. The fsadm command is also there but the only possible options are -F <FStype> and -o <specific_options>. So I guess it's mandatory to unmount the file system before you extend it on 11iv1.
Looking for logical volumes, volume groups and disks
Basic usage
See what disks are available (-k for kernel I/O system data structures),
ioscan -fnkC disk
diskinfo /dev/rdsk/c0t0d0
diskinfo /dev/rdsk/c3t6d0
Note. "diskinfo -v" for more details
Note. Here's a little script if you are tired of counting kbytes yourself (http://pbraun.nethence.com/scripts/sysutils/hpux/diskspace.ksh).
Have a quick look on the available volume groups and used disks,
strings /etc/lvmtab
See the LVM physical volume details on the used disks,
pvdisplay /dev/dsk/c3t6d0
See all the volume groups, their child logical volumes and the corresponding physical volumes,
vgdisplay -v | grep Name
See how much space you got left on vg00,
vgdisplay vg00
Note. Here's a little script if you are tired of calculating the free PE's yourself (http://pbraun.nethence.com/scripts/sysutils/hpux/vgspace.ksh)
See how much space is available on the mounted file systems,
bdf
Increase the size of a filesystem (draft in progress)
I am assuming you've got enought space left in vg00 to extend lvol6 (/opt/).
Reboot into single user mode,
shutdown -r -y now
Main Menu: Enter command > boot
Interact with IPL (Y, N, Q)?> y
ISL> hpux -is /stand/vmunix
get to your environment and set TERM,
mount -a
umount /opt/
su -
extend the logical volume and filesystem you need to extend,
lvdisplay /dev/vg00/lvol6 | grep 'LV Size'
vgdisplay vg00 | grep Free
lvextend -L 2048 /dev/vg00/lvol6
extendfs /dev/vg00/lvol6
^D
sync
reboot
Adding a new disk
Assuming there is a second disk you want to place some data on,
ioscan -funC disk
pvcreate /dev/rdsk/c3t5d0
cd /dev/
mkdir -p vgdata/
cd vgdata/
mknod group c 64 0x010000
vgcreate vgdata /dev/dsk/c3t5d0
vgdisplay vgdata | grep 'PE'
lvcreate -l 2169 -n lvdata vgdata
newfs -F vxfs /dev/vgdata/rlvdata
add this to fstab,
/dev/vgdata/lvdata /data vxfs delaylog 0 2
and mount the volume,
mkdir -p /data/
mount /data/
Additional notes
Eventually backup your configuration,
vgcfgbackup vg00
mkdir -p ~/backup/
cp /etc/lvmconf/vg00.conf ~/backup/